top of page
paulcapatana

How to configure IS-IS routing protocol

1.What does IS-IS stands for?

IS-IS – stands for Intermediate system to Intermediate system

IS-IS protocol is extensively used as Interior Gateway Protocol (IGP) in Internet Service Provider (ISP) environment. The scope of this document is to provide information regarding IS-IS area types and configuration .

IS-IS is hybrid link-state protocol from same family like OSPF .

By hybrid I meant the fact that it’s a 2.5 Layer routing protocol because the adjacency could be done either using the layer2 address ,either using the layer3 address


2. How it works ?

IS-IS Areas

In OSPF protocol any of the router’s interfaces can be assigned to a particular area, however the concept of area in IS-IS is different. Here in general, every single router belongs to an Area. The idea of this comes from the fact that IS-IS was initially created to route Connectionless Network Protocol (CLNP) where the address belongs to a device (Router), whereas in Internet Protocol (IP) the address belongs to the particular interface.

IS-IS protocol has two levels or hierarchy, Level 1 and Level 2. Level 1 corresponds OSPF intra-area routing whereas Level 2 corresponds with the OSPF backbone Area 0 routing. Level 2 areas join all the areas with the backbone area.

A Level 1 router can become adjacent with the Level 1 and Level 1-2 (L1/L2) router. A Level 2 router can become adjacent with Level 2 or Level 1-2 (L1/L2) router. There is no adjacency between L1 only and L2 only router.

IS-IS Level 1 (L1) Router

An IS-IS Level 1 router has the link state information of its own area for all the intra-area topology. In order to route packets to other areas it uses the closest Level 2 capable (L1/L2) router. Level 1 Area behaves pretty much as OSPF totally stubby area. L1 only router send L1 Hellos.

IS-IS Level 1-2 (L1/L2) Router

An IS-IS L1/L2 router maintains two link state database information. One is for Level 1 and the other for Level 2.Hence two distinct Shortest Path First (SPF) calculations are run, one on Level 1 link state database and other on the Level 2 link state database. IS-IS Level 1-2 router behaves very close to OSPF Area Border Router (ABR). L1/L2 router sends both L1 and L2 hellos.

As default behavior L1/L2 router will only allow one way passage of prefixes from L1 Area to L2 Area, but not in reverse.


However if it is required to move prefixes from L2 Area to L1 Area then redistribute command under IS-IS configuration is required.

IS-IS Level 2 (L2) Router

An IS-IS Level 2 router has the link state information for the intra-area as well as inter-area routing. L2 router sends only L2 hellos. IS-IS Level 2 area can be compared with OSPF backbone area 0.


3.How to configure the IS-IS routing protocol

As mentioned this protocol can be configured in two ways and even if it might look scary at first glance it’s not so scary after all and you’ll see that after we’ll show how it’s configured


Let’s see the first way of configuring , the one using the layer 2 address

For this exercise we’ll use the below shown topology


We need to configure the interfaces as shown in below table



Now let’s configure the router interfaces as shown below

R1

interface Loopback11

ip address 11.11.11.11 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 10.1.1.1 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

R2

interface Loopback22

ip address 22.22.22.22 255.255.255.255

ip router isis


interface GigabitEthernet0/0

ip address 10.1.1.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown


interface GigabitEthernet1/0

ip address 172.16.10.1 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

R3

interface Loopback33

ip address 33.33.33.33 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.10.1 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

!

interface GigabitEthernet1/0

ip address 172.16.10.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

R4

interface Loopback44

ip address 44.44.44.44 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.10.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown


Now that we’ve configured the interfaces let’s proceed further with IS-IS protocol configuration as shown below


R1

First we write down the MAC address of the physical interface configured earlier because we’ll need it later.



As you’ll see this address it’ll be part of the network address

The network address is composed by 4 octets

First two octets from de net command mark the area , next three octets are related either to the MAC address mentioned earlier or to the IP address configured on the interface and that type of configuration we’ll be shown a bit later, the last octet is called N selector and is always 00


router isis

net 49.0001.ca01.05e4.0008.00

is-type level-2-only

log-adjacency-changes

If everything is done right then below message would be displayed


R2

router isis

net 49.0001.ca02.05f4.0008.00

is-type level-2-only

log-adjacency-changes

if everything is done right then below message would be displayed


R3

router isis

net 49.0001.ca03.0604.0008.00

is-type level-2-only

log-adjacency-changes

if everything is configured correctly then below message would be displayed


R4

router isis

net 49.0001.ca04.0614.0008.00

is-type level-2-only

log-adjacency-changes

If everything is configured right then below message would be displayed

Now let’s check to see the neighbors status on each router


In order to do that we’ll use the command : show isis neighbors





Now let’s check the routing table on each router





In each of these routing tables we noticed that we’ve received routes from ISIS neighbors (the ones marked with i L2)


Now let’s test the bidirectional connectivity between R4 and R1




Now let’s see the second way of configuring the IS-IS protocol , using the IP address configured on the physical interface

For this purpose, we’ll use same topology


This time we’ll change the IP addressing a bit configuring as shown in below table


The interfaces configuration is similar with the other way of configuring , only the IPs differ , so let’s see how it looks on each router :

R1

interface Loopback11

ip address 11.11.11.11 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.16.20.1 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown


R2

interface Loopback22

ip address 22.22.22.22 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.16.20.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

!

interface GigabitEthernet1/0

ip address 172.16.10.1 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown


R3

interface Loopback33

ip address 33.33.33.33 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.10.1 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

!

interface GigabitEthernet1/0

ip address 172.16.10.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown


R4

interface Loopback44

ip address 44.44.44.44 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.10.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

!


Now that we’ve configured the interfaces let’s proceed further with IS-IS protocol configuration as shown below

R1

router isis

net 49.0001.0172.1620.0001.00

is-type level-2-only

log-adjacency-changes

If everything is done right then below message would be displayed

R2

router isis

net 49.0001.0172.1620.0002.00

is-type level-2-only

log-adjacency-changes

If everything is done right then below message would be displayed

R3

router isis

net 49.0001.0172.1610.0002.00

is-type level-2-only

log-adjacency-changes

If everything is done right then below message would be displayed

R4

router isis

net 49.0001.0172.2010.0002.00

is-type level-2-only

log-adjacency-changes

If everything is done right then below message would be displayed


Now let’s check to see the neighbors status on each router






Now let’s check the routing table on each router






Now let’s test the bidirectional connectivity between R4 and R1




I hope that now the IS-IS routing protocol looks a bit less scary than it looked initially 😊

I also hope that this document have been informative and useful for whom is interested to know more and to understand how this routing protocol works.

37 views0 comments

Comments


Post: Blog2_Post
bottom of page